Le plugin pour Firefox, FireFtp n'est pas compatible, pour l'instant, avec Firefox 3.5.
Fireftp.jpg
C'est un des plug-in que j'utilise le plus.
J'espère que ce sympathique programmeur nous proposera une mise à jour rapidement.

Sources:
http://fireftp.mozdev.org